Honda Motorcycles - FireBlades.org banner
1 - 8 of 8 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
Hi crew I'm hoping to get some help I have not been riding my bike but start it once a week to warm enough to ride then turn the beast of ,but today the battery was slight flat and the fuel pump never primed the bike turned over but no start I charged it and had the same results I che ked all the fuses and they were OK I heard a click nosie that i had never noticed
before coming from the black box under the fuse box I'm thinking a relay may have failed? I'm spewing because I have not been riding and parts are failing please help 馃榿馃憤
 

Registered
Joined
84 Posts
Hi crew I'm hoping to get some help I have not been riding my bike but start it once a week to warm enough to ride then turn the beast of ,but today the battery was slight flat and the fuel pump never primed the bike turned over but no start I charged it and had the same results I che ked all the fuses and they were OK I heard a click nosie that i had never noticed
before coming from the black box under the fuse box I'm thinking a relay may have failed? I'm spewing because I have not been riding and parts are failing please help 馃榿馃憤
Sorry to hear this as it can be very frustrating. Mine has done it twice. First time it was a loose connection in the way Honda runs the wires through the fuel pump, to get the wires from outside to inside. The second time it was the ground block near the ecm. On this you will look for a bunch of green wires going into a yellow plastic. Mine was very obvious as part of it had melted. Hope this helps.
 

Registered
Joined
1,733 Posts
Battery terminal all tight? I assume it cracks over ok but no start - if that's the case check there is power to the fuel pump when cranking, 12v feed to injectors and coils - most obvious fail points. Bad earthing are worth an investigation. I presume all lights etc work ok so its on the engine circuits? btw there is no need to start a stored bike every week - probably doing more harm than good to be honest...
 

Registered
Joined
7 Posts
Iv pluged in my fuel pump from my 929 and it is not priming or making any sound at all in or out of fuel there is a ticking sound or a tick as the bike would usually do its priming sequence it makes a click nosie once that's it one from the ignition block between the handle bars like normal and one from the left hand side of the bike where the rectifyer is ? The fluted finned cooled rectangular unit? Anyway from there I'm going to try and find power somewhere or why there is no power going to the pump maybe the thing im thinking is a rectifyer is a relay ? I must check my manual cheers any help is appreciated as you can tell I'm not very mechanically knowledgeable
 

Registered
Joined
84 Posts
Iv pluged in my fuel pump from my 929 and it is not priming or making any sound at all in or out of fuel there is a ticking sound or a tick as the bike would usually do its priming sequence it makes a click nosie once that's it one from the ignition block between the handle bars like normal and one from the left hand side of the bike where the rectifyer is ? The fluted finned cooled rectangular unit? Anyway from there I'm going to try and find power somewhere or why there is no power going to the pump maybe the thing im thinking is a rectifyer is a relay ? I must check my manual cheers any help is appreciated as you can tell I'm not very mechanically knowledgeable
The tick sound would be the relay working. There are a lot of fuel pump threads on here. Did you search this forum?
 

Registered
Joined
7 Posts
what model is it? 929/954 fuel relay is under the seat. you can swap/bypass it to see it ifs at fault
It's 2004 cbr1000 I have a 929 that I need case's for the motor as i broke the swing arm off the motor but iv had to reboot my phone to factory settings because of malware I picked up and now do not have a manual for the bike so if there is a download any one knows of that would help cheers crew
 

Registered
Joined
88 Posts
It's 2004 cbr1000 I have a 929 that I need case's for the motor as i broke the swing arm off the motor but iv had to reboot my phone to factory settings because of malware I picked up and now do not have a manual for the bike so if there is a download any one knows of that would help cheers crew
Hi matey might be worth starting your own post, with the problem you have(y)
 
1 - 8 of 8 Posts
Top