Honda Motorcycles - FireBlades.org banner

1 - 6 of 6 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1 (Edited)
I got it all installed and figured which wires and all was good and now its just a solid yellow. I don't have the flasher relay cause read I wouldn't need it for the rear. But funny thing one of the green wires on the green and orange touched the orange and they both magically worked. It has the power signal and ground connector on the light and 2 yellow wires for left and right the left is on the orange wire for left blinker and the right is on the solid blue for the right. Have I got this hooked up right or will I need the relay ??:idunno:
 

·
Registered
Joined
·
60 Posts
Turn signals flash because of the OEM flasher relay that ALL vehicles have.
There may be an exception to that as electronics take over but, lets say all for now.
If you take it out, you dont flash, if it fails you dont flash.
So you tell me if you need it?
 

·
Registered
Joined
·
70 Posts
Discussion Starter #4
The factory relay is in there. That is not the issue I dont believe it works just dont flash but if I touch the ground to the signal wire it works fine.
 

·
Registered
Joined
·
45 Posts
If you hook the right wires up but still not in the technically correct order, it will just stay on. Just switch em, it might take a couple tries, I've been there too.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
thanks man I will try that tomorrow when i get home. they do tend to come on at times and work. they also come on in the right direction as well if me swapping them would that not change them up signal wise?
 
1 - 6 of 6 Posts
Top