Honda Motorcycles - FireBlades.org banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I'm new to the site and have recently bought a 99 blade. I just started getting used to it and found a what feels like a misfire or rev limiter coming on @ 8000/9000rpm. It won't seem to pull past these revs. I've changed to oil and filter as matter of course and fitted new plugs too. I've fitted new plug leads and caps and even removed the 5K resistor from the cap. I've tried closing the plug gap up but still same. Put the gap back and tried different coils, tried different ECM and different crank pick up. but nothing made any difference, the parts were from a mates '95 model. even though his bike didn't have a throttle position sensor the fault was exactly the same. I did notice the '95 model had a fuel pump too but mines not got one? I'm starting to think it it carburation. Forgot to say, I've had the carbs to bits and cleaned out but no change. The bike has got a twin exhaust and a k&n air filter too, the bloke who I got it off said it has a dynojet fitted but I wouldn't know what this consisted of if I saw it. Going to try the carbs off the '95 model next. What size jets should my '99 model have? the needles seem to have a double taper too, is this right? Any help/advise appreciated. Starting to run out of ideas.
Thanks...............Boost.
 

·
Registered
Joined
·
37 Posts
hi there are you aware that a lot of grey imports come into the country factory restricted? maybe you should try down this road also learner drivers would need to restrict ther machines. :idunno:
 
1 - 2 of 2 Posts
Top