Honda Motorcycles - FireBlades.org banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey everyone so im new to this forum so ahead I thank everyone who can give me advice, I'm having a major problem with my bike that started last week, I have an 02 954 with 12k miles on it starts great idles great, throttle response in good, but my issue is no matter what gear I'm in whenever I hit around 9k rpm the red light by the directional light pops on and the motor cuts out until the rpm drops below 9k then the light goes out and I have throttle response again. It doesn't completely shut off just kills my power and takes throttle away at 9k rpm, and no fi light when this happens just the red at the top, anyone has any ideas what this might be?????
 

·
Premium Member
Joined
·
897 Posts
Hi and welcome.

Sorry I can't help with the problem, but a guru might suggest there's a prob in the ECU with the rev limiter.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
So your thinking the ecm might be going bad? Should ingetva new one, every one I talk to has no idea nor ever hear this happening
 

·
Registered
Joined
·
320 Posts
Hey everyone so im new to this forum so ahead I thank everyone who can give me advice, I'm having a major problem with my bike that started last week, I have an 02 954 with 12k miles on it starts great idles great, throttle response in good, but my issue is no matter what gear I'm in whenever I hit around 9k rpm the red light by the directional light pops on and the motor cuts out until the rpm drops below 9k then the light goes out and I have throttle response again. It doesn't completely shut off just kills my power and takes throttle away at 9k rpm, and no fi light when this happens just the red at the top, anyone has any ideas what this might be?????
Brolley,

Are you running a Power Commander 3 on it? If you are, disconnect it and see what it does. In my experience, a PC3 went out and it would not allow the bike to rev past 8-9k rpms and gradually got worse.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I am not running a pc3 the bikes mainly stock still, and only has 12k miles, a week ago i could red line it all day and it would take it like a chamo but now the second it hits 9k in any gear it's like you just took your hand off the throttle with the jolt forward and no response with the red light at top coming on until it lowers to about 8800 rpm then I get throttle back instantly
 

·
Registered
Joined
·
17 Posts
Hi there.
Is it flashing any codes at all?
Maybe an airleak?

If it turns out to be the ecm I got one for sale ;)
Although it's an european version with HISS and all digeldongels.
You from states or where?

Turned out that my problem wasn't the ecm and now I got a spare one!
 
1 - 9 of 9 Posts
Top