Honda Motorcycles - FireBlades.org banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just bought my 954 a couple months ago and had no problem with it. A week ago it had a problem turning on it would start but cut off. I changed my spark plugs and put a new air filter on it but the problem still proceeded. I'm kinda scared to ride ot just incase it shuts off on me on the high way. what could I do to fix this problem?
 

·
Registered
Joined
·
245 Posts
Have you tinkered with the bike prior to this problem showing up btw ?

An air filter wouldn't be the culprit (even if it was pretty filthy). Plugs, maybe - if they were very fouled but usually that causes a "crank/no fire" condition.

Start with the obvious first: Are the battery terminals tight? This is often overlooked & should be doublechecked.

Also, were there any noticeable symptoms prior to the engine just "turning off" on you while you were out riding around (ie - low/stumbling idle, dimming headlamp, etc) ?

How many miles on the engine btw and what kind of overall condition is this new-to-you bike in ? Hopefully it wasn't someone's basketcase of a problem and pawned off to an unsuspecting buyer (you).
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The bike has 44800 miles and I havent messed with the bike at all. The bike turns on and runs but only issues is when ima start it. I either hold down the button and slightly pull the throttle then it will turn on and a little bit. But it never did that before.
 
1 - 4 of 4 Posts
Top