Honda Motorcycles - FireBlades.org banner

1 - 20 of 120 Posts

·
Registered
Joined
·
1,820 Posts
l'timbré said:
yo newfie what's the deal with the popcorn? why don't you talk about your pos bikes :evilaugh:
Cause the subject is 'Blades, and unfortunately, I don't own one. So I'm just a spectator. Kinda like a movie I guess. :D
 

·
Premium Member
Joined
·
2,692 Posts
I've only racked up 3,400 miles on the 954 but probably 50% (or more) of them are on the track. No problems at all. :thumb: :thumb:
 

·
Registered
Joined
·
1,657 Posts
I had 49,800 kms on the old 929 and NEVER had a problem with it, I had the valve clearances checked 3 times and it never even needed to be shimmed :thumb: changed the plugs 2 or 3 times(iridium is the way to go) and other than oil changes I did nothing...awsome reliability and great performance too :thumb:

I only have around 6000kms on the new 1000rr and I have had the C.C.T. changed as well as the speedo/tach, but other than that it has been great too...gotta love a honda :thumb:
 

·
Registered
Joined
·
14,224 Posts
7K on the 1000RR only tires and gas
20K and 20 years on the Ascot engine still runs great need to adjust the valves and it was laid down pre-sheep and the clutch tang broken on the side case (planning on replacing it before it is not possible) also needs new brake lines, fork seals and rear shocks soon.
 

·
Registered
Joined
·
79 Posts
36,000HARD kms, 1 clutch, dropped 2x, 3 sets of tires, 2 new chain/sprockets, new numerous oil changes.....

Due to dropping - new magneto, flywheel, forks, clutch lever......
I've had her 1 year...never dropped her...slowly fixing the neglct and abuse of this once proud RR(T)
 

·
Registered
Joined
·
686 Posts
28k miles on a CBR 929 and the horn didnt work. Every honda I ever owned had a problem with a button on a switch going out. Other than that they worked very well.

The turnsignal spring on my tuono went out at 500 miles too.. so maybe its just me.
 
1 - 20 of 120 Posts
Top