Honda Motorcycles - FireBlades.org banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
What took me so long to join? Should have joined a long time ago. Anyhow, good to be here. Still love my Black/Titanium '03 CBR 954 RR. After 70K+ miles, we've had a lot of time together.
Look forward to getting started on this forum. I may not have all the time in the world with all my kids grabbing for my attention, but it'll be fun.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Re: Electrical problems- Duh, who put the lights out?

Question: am I posting the right way? Just trying to start a thread about electrical/head light problems.

If this is the right place, here goes. Six months ago, after a track day, I re-connected my headlights, and 2 blew, then after testing/switching them around, the 3rd bulb blew.
Got new bulbs (left out low beam bulb) and everything fine for 4 months. Til a few weeks ago. Turned key, no headlights. All bulbs (filaments) intact. Tried replacing bulbs, but no luck. Makes cliking sound at the rear cowl, specifically, the hind-most starter relay.

(May be unrelated, but back in Sept/Oct, 4th gear stopped engaging. Then in November I went down (rear tire spin in 30 degree weather :crap: ), and the odometer/speedometer stopped working.)

Checked out all the wires I could. Regulator rectifier and wires into area in front of battery all looked good. No melted wires.

Stinks to not be able to ride at all. Any ideas?
Thanks.
 

·
Registered
Joined
·
2 Posts
hi friends

Looks like a happening crowd here. I'm Rick from LA and hoping to get into interesting discussions.
 
1 - 7 of 7 Posts
Top