Honda Motorcycles - FireBlades.org banner
1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I havE a 954 I bought it and it was laid down I put all the new plastic on it and it ran great. I went to start it and it just clicked I checked everything it ended up being the starter wire after that I started it right up I went to take off and it sputtered and stalled so I put a gallon of gas in it. I then tried to start it and it turns over great it just won't fire at all? I'm not sure where to go now to determine what the problem is because it was running great and would just fire right up please help!!!
 

·
Registered
Joined
·
902 Posts
check the tilt switch first, make sure its working right and that its connected right. If ok go for new set of plugs they can often be the only prob:thumb: Oh! if you have a power commander disconnect it as they can cause the same prob!!
 

·
Registered
Joined
·
4 Posts
hi guys...i'm having the same problem with my 954...fuel pump primes and bike wont fire... occasionally bike starts and runs fine then next time i come to it it turns over and doesnt fire again...fuel pump purges every time tho...does anyone know the location of the tilt switch please so i can check it and what does it look like...thanks for any help
 

·
Premium Member
Joined
·
32,104 Posts
hi guys...i'm having the same problem with my 954...fuel pump primes and bike wont fire... occasionally bike starts and runs fine then next time i come to it it turns over and doesnt fire again...fuel pump purges every time tho...does anyone know the location of the tilt switch please so i can check it and what does it look like...thanks for any help
Have you checked the fuel pressure regulator?
What do you mean the fuel pump "purges"?
The bank angle sensor is a black box mounted on the back of the headlight.
 

·
Registered
Joined
·
4 Posts
pressure regulator is fine and by purges i mean when ignition is turned on fuel pump pressurises fine just doesnt fire which made me think it could be the tilt switch...just didnt know where it was located...thanks for the info...will go check it now :)
 

·
Registered
Joined
·
4 Posts
i cant find anything on the back of the headlight...is it ever anywhere else ?... and if not then it must just be my tired old eyes that are going blind lol so where exactly is it on the headlight and what does it look like...thanks again in advance for any help offered
 

·
Premium Member
Joined
·
32,104 Posts

·
Registered
Joined
·
14 Posts
I had similar problem on my 954 after i bought it. It ran great then one day it would turn over strong and prime and everything except start. I threw new plugs in it, messed with the power comander III and checked out everything...turns out i finally paid the shop to charge my battery. If the battery is somewhat low it will crank but wont start the bike, charge ur battery over night on a trickle charger, see if that helps
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top