Honda Motorcycles - FireBlades.org banner

1 - 9 of 9 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
I had all my plastics off my bike for about 2 months was working on some cracks and I just put everything back together and tried to start it and nothing, lights dont turn on doesent crank over, i checked to see if my battery is charged and it is check my ignition fuse its fine. I rode the bike before I parked it so can someone give me some advice
 

·
Registered
Joined
·
7,366 Posts
If all of them are ok, check the red killer switch on the R/H switch gear.

Does the ignition come on at all? Does the fuel pump prime?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #5
It was a fuse that was right next to the battery. After I got it started I went for a short ride and laid it over...maybe I shouldnt have gotten it started. They put sand down on the roads here and i hit some taking a turn.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #8
Umm Im not sure whats wrong with my shoulder I think its just really soar I landed on it I was going about ten, I was wearing my full leathers and helmet so just bruised up hopefully it gets better soon. The bikes nose and right side fairings are messed up not the tail though. Im going to fix the two side pieces and I have to buy a new nose and brake lever. I had it all preped and ready to be painted :thumbd: sucks but **** happens shouldnt have been riding it in winter anyways huh
 

·
Registered
Joined
·
108 Posts
Discussion Starter #9
Ohh yea and my speedo didnt work when i took it out and it worked before what would cause that? I did wash it could water be the cause
 
1 - 9 of 9 Posts
Top