Honda Motorcycles - FireBlades.org banner

1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have a 954rr the red light has been flashing but goes away after the engine hits about 3000 rpm, also its been making a flickering noise that gets faster as the speed increases. the noise has gotten louder over a few days then I noticed the bike was losing a lot of power. the bike has no trouble starting up at doesn't over heat. its not leaking any fluids. when I got it, I noticed it was over full on oil, so I drained it an went from semi synthetic to full synthetic, also put some ngk laser iridium plugs in it.

if you can help or have any advise id appreciate it.. thanks
 

·
Super Moderator
Joined
·
32,034 Posts
I have a 954rr the red light has been flashing but goes away after the engine hits about 3000 rpm, also its been making a flickering noise that gets faster as the speed increases. the noise has gotten louder over a few days then I noticed the bike was losing a lot of power. the bike has no trouble starting up at doesn't over heat. its not leaking any fluids. when I got it, I noticed it was over full on oil, so I drained it an went from semi synthetic to full synthetic, also put some ngk laser iridium plugs in it.

if you can help or have any advise id appreciate it.. thanks

Do you mean the oil light?
If it is then I'd be looking at rod bearings.
Can you video the light and the noise?
 

·
Super Moderator
Joined
·
32,034 Posts
NO ITS NOT THE OIL LIGHT, ITS THE RED LIGHT ON THE DASH THAT BLINKS

Okay, it's flashing even when the engine is not running then?
Have you counted the long and short flashes to read the code as described in the manual?
 

·
Super Moderator
Joined
·
32,034 Posts
I have a 954rr the red light has been flashing but goes away after the engine hits about 3000 rpm, also its been making a flickering noise that gets faster as the speed increases. the noise has gotten louder over a few days then I noticed the bike was losing a lot of power. the bike has no trouble starting up at doesn't over heat. its not leaking any fluids. when I got it, I noticed it was over full on oil, so I drained it an went from semi synthetic to full synthetic, also put some ngk laser iridium plugs in it.

if you can help or have any advise id appreciate it.. thanks

This is a good indicator of a failed fuel pressure regulator diaphram, make sure the vacuum hose is not sucking fuel when the ignition is on.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
IT ONLY FLASHES WHEN THE ENGINE IS RUNNING, AN IV TRIED TO COUNT THE FLASHES BUT THE ONLY TIME IT SEEMED TO WANT TO FLASH WAS WHEN I WAS RIDING,
 

·
Super Moderator
Joined
·
32,034 Posts
IT ONLY FLASHES WHEN THE ENGINE IS RUNNING, AN IV TRIED TO COUNT THE FLASHES BUT THE ONLY TIME IT SEEMED TO WANT TO FLASH WAS WHEN I WAS RIDING,
So it doesn't flash while the bike is running stationary, only while you ride?
Can you post a video?
 
1 - 7 of 7 Posts
Top