Honda Motorcycles - FireBlades.org banner

1 - 9 of 9 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
what's up guys I have an issue just got my blade back together started it up let it warm up and the oil light came on ckd the oil level it is good( using royal purple 10w-30) reved the motor a little and the light went out during normal ridding it stays off till I idle. as soon as it idles light comes on I did the ck the the manual calls for and it is good. any one else have this problem and what did you do? the sensor must be working cause the light goes out any one got a clue.

thanks in advance
Alter
 

·
Registered
Joined
·
38 Posts
What did you have it apart for? The light should come on due to a problem with the oiling system like low pressure not low oil.
 

·
Super Moderator
Joined
·
32,034 Posts
what's up guys I have an issue just got my blade back together started it up let it warm up and the oil light came on ckd the oil level it is good( using royal purple 10w-30) reved the motor a little and the light went out during normal ridding it stays off till I idle. as soon as it idles light comes on I did the ck the the manual calls for and it is good. any one else have this problem and what did you do? the sensor must be working cause the light goes out any one got a clue.

thanks in advance
Alter
Sounds like low pressure.
The oil level is okay with the bike upright?
How low is the idle set?
Was the engine apart?
 

·
Registered
Joined
·
49 Posts
Discussion Starter #4
had the bike apart to powdercoat the frame, the oil level is good, the idle is set about 950 after warmed up, yes the engine was apart but it is put back together to factory or better specs the only part that isn't new is the oil pump,I am going to drain the oil remove the pump and check the clearance of the vain to the housing, besides that I have no clue. the tach oon the bike doesn't work so I am using my snap on tach to get true revs and I have an external oil pressure gauge hooked up now it has oil pressure, but I am not sure how much it takes to turn the light out not listed in the manual. think i might take the sensor out and us air pressure and my multi meter and figure out at what pressure it takes to make the switch break contact. I did the oiling system ck that is in the manual and it is as spec. if there is anything else I am missing let me know
 

·
Super Moderator
Joined
·
32,034 Posts
had the bike apart to powdercoat the frame, the oil level is good, the idle is set about 950 after warmed up, yes the engine was apart but it is put back together to factory or better specs the only part that isn't new is the oil pump,I am going to drain the oil remove the pump and check the clearance of the vain to the housing, besides that I have no clue. the tach oon the bike doesn't work so I am using my snap on tach to get true revs and I have an external oil pressure gauge hooked up now it has oil pressure, but I am not sure how much it takes to turn the light out not listed in the manual. think i might take the sensor out and us air pressure and my multi meter and figure out at what pressure it takes to make the switch break contact. I did the oiling system ck that is in the manual and it is as spec. if there is anything else I am missing let me know
950RPM is way too low.
Wind it up to 1200RPM and see if that fixes the oil light.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #8
lol this thing will idle all the way down to 475rpms when I bought the bike I completely rebuilt the motor to be "tight" with the intent of running mulitiple stages of juice when I get time to add that on after I break the motor in haven't had time to reset the idle yet plan on doing that first thing in the morning and will post the result as soon as I know

Alter
 
1 - 9 of 9 Posts
Top