Honda Motorcycles - FireBlades.org banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hi i just joined your club cause i seen that you guys were actually helpful with one another. I've had my 954 since march had 10,000 miles when i i bought it i rode it for a month or so then had the oil changed by a technician supposedly when i got it back it cranked ran for about 3 minutes then shut off. I got online and paid to talk to a guy who said it was my spark plugs so i had those changed. The bike cranked and runs now but i'm still getting 9 long blinks and the fi light is on. If one of you guys could just help me i'm no bike gooruu by any means and i come to you very humble. The bike runs but when i crank it i have to hold the throttle for about 10 to 15 seconds so it will idel the shop i'm near in fredericksburg doesn't have the machine to hook it up too and i just wanna ride while i still can. Please please i repeat someone please help me my baby is sick and i want to get it fixed but noone around her can help me. Thanks guys
 

·
Registered
Joined
·
52 Posts
hi i just joined your club cause i seen that you guys were actually helpful with one another. I've had my 954 since march had 10,000 miles when i i bought it i rode it for a month or so then had the oil changed by a technician supposedly when i got it back it cranked ran for about 3 minutes then shut off. I got online and paid to talk to a guy who said it was my spark plugs so i had those changed. The bike cranked and runs now but i'm still getting 9 long blinks and the fi light is on. If one of you guys could just help me i'm no bike gooruu by any means and i come to you very humble. The bike runs but when i crank it i have to hold the throttle for about 10 to 15 seconds so it will idel the shop i'm near in fredericksburg doesn't have the machine to hook it up too and i just wanna ride while i still can. Please please i repeat someone please help me my baby is sick and i want to get it fixed but noone around her can help me. Thanks guys
A machine to hook it up to?? The engine codes simply blink. Count the slow blinks and then the fast blinks, each will be a number in the error code. Once you've established the code im sure google will tell you what its correlating to. Sounds like a fuel issue, possibly bad fuel pump or injectors are clogged.
 

·
Registered
Joined
·
6 Posts
Dont know if this will help, but when i had my 929, the fi light came on often. would give different codes, but everytime it turned out to be a bad servo motor. go figure. had to have it changed a few times. now my 1000 is ticking me off with an ignition prob of some type, so dont feel too bad ;~)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top