Honda Motorcycles - FireBlades.org banner

1 - 4 of 4 Posts

·
Registered
Joined
·
318 Posts
Discussion Starter #1
Ok, so I got a used power commander and put it on. The bike idled rough and smoked. Also, the red malfunction indicator lamp came on, as well as the FI light. I figured the PC3 was shot, so I removed it, but the bike still idles really rough and the lights remain on. I've checked all the plugs to make sure they're plugged in, but I did unplug lots of them, and I'm worrying that I broke a connection in the old brittle wiring. If someone can help me PLEASE let me know!! I need my baby!!!:crying:
 

·
Registered
Joined
·
318 Posts
Discussion Starter #2
Ok, I have a new development. I took it to the gas station, and noted 3 things. The bike idles terribly, almost dieing, until the malfunction light lights up and the FI indicator comes on. Then it runs PERFECTLY, no hesitation or anything. Also, the light stays on solid when you are going and have the kick stand up. If the kick stand is down, however, the malfunction indicator light blinks twice, then goes off. Blinks twice, goes off. I know this is a code for something, but I don't know what. A call to the local honda dealer is in order tomorrow, but I would rather fix it myself rather than pay someone $70 an hour to chase down an electrical problem.
 

·
Registered
Joined
·
318 Posts
Discussion Starter #4
They were 2 short blinks. I called Honda and they said it was my MAP sensor. I ordered a service manual yesterday as well. Thanks!
 
1 - 4 of 4 Posts
Top