Honda Motorcycles - FireBlades.org banner

1 - 12 of 12 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
ok as you all know i got a 954 for cheap but then put a load of money into it and all has been while and im more then happy with the bike but my red light come on about 300 miles from home (did not change anything about the bike at all in any way) but i would like to know what it is so i can fix it... iv checked in my heyns book and nothing found. any help ?

thanks, JoshW
 

·
Registered
Joined
·
97 Posts
Red light? Hmm... On these do they have a check engine light? Or is that the oil light? If its a check engine like, then you probably have something wrong with the "running" of the bike... This could be anything from ignition problems to well, oil problems... I would say get it somewheres that can find out exactly whut it is, unless your mechanically inclined and have the correct electronics to figure it out... Nevertheless, good luck with it... Is the light staying on constantly though or does it come on after a while?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
only sends it when the bike is not started just key is on.... and yes it does have a oil light right under the fi light but its not on. at all
 

·
Super Moderator
Joined
·
32,034 Posts
Sounds more like a 34 which is the servo motor.
Very common and doesn't prevent the bike from starting as injector faults do.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #9
the the bike dose fine at all rpm's and in all gears i just got back form the Honda dealer and ordered a new map sensor. and new air filter as well. iv got to give it to the 954 owners ... this bike is awesome and im now a true cbr fan.

also thanks to bigbassturd for helping me out if there is anything i can do just ask... you always reply to my post with helpful tips thanks man.
 

·
Super Moderator
Joined
·
32,034 Posts
The MAP sensor error is usually just the vacuum hose dropped off or the connector is loose.
 
1 - 12 of 12 Posts
Top