Honda Motorcycles - FireBlades.org banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
HELP!!!!

I jus got my 04/05 Fireblade with just below 37k kilometers on the clock 4 days ago. The day i got her i rode her home (about 14km) and i didn't push her limits once. However on getting home i realised just as i was about to turn her off that the red light was on. She has been parked since, but yesterday after taking off some fairings to check on the quality of the coolant and checking for oil leaks etc (everything checked out pretty well) i decided to fire her up and let her warm up until the fan kicks in. This was my idea of knowing that the thermos and fan was working. She fired right up, idled perfectly and had no lights. At about 105°c i noticed the red light started flashing along with the oil light. The fan does come in and the temp drops as expected but the oil light and the red light flashing had me up all night. Please help with any leads as to what could be the cause of this. I am yet to do an oil change before i start riding her much but the oil level and color looks good from the little glass. Please help a brother. 🥵
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Rectangle Font Parallel Slope Diagram

So i was reading the owner`s manual and i come across this. Please tell me it doesn't mean what i think because i really feel stupid right now.
🤦‍♂️
 

·
Registered
Joined
·
1,659 Posts
I've never seen the oil pressure light flicker on any bike I've had, even hot at idle speeds even after thrashing it on a track day. I'd still check the level and I wonder when it was last changed, or if a the right grade of oil was used - too thin perhaps? I appreciate its done a few miles (or km's!), but that's about 1/2 the miles of my 929. Perhaps someone with an early-ish 1000cc might have more experience..
 
1 - 4 of 4 Posts
Top