Honda Motorcycles - FireBlades.org banner
1 - 9 of 9 Posts

·
Registered
Joined
·
479 Posts
Discussion Starter · #1 ·
Found a fried connection from stator to RR the other day after the bike left me stranded. Stators on the way....I am curious though, with the exception of the stator connection and RR to battery clip where else should I look for important connections? Id like to check all the major connectors to make sure there arent anymore fire hazards.?.?
 

·
Registered
Joined
·
11 Posts
I dunno about your stator, but you seem to have fried this forum with all your stator questions, Tim :flame: !!

Have you seen this thread - you gotta read it - this advice is like gold dust...

I'm about to order a new stator (took my fried one out on Monday) but like you I want to check out that earth connection to make sure the next stator doesn't fry within the month too...
 

·
Registered
Joined
·
26 Posts
Yep, same thing happened to me. ended up in a ditch because my lights went out.. All the earth connections are under the right hand side of the fuel rail and when you get the tank off you can't help but loose some petrol which seeps down the wires and into the earth block. Mine were crisp when i found them. loads of electrical problems before finding this, new reg/rec, 2 alternators, fuel tank pump, tested loads of other stuff. Soldered all the earths together and no more probs! This was a couple of years ago. Definately worth a check if you have continuing problems, or as the RRY/RR1 blade is now 10 years old check them anyway.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #6 ·
Well....I rewired and used a solder joint to re-ground my main harness, and I installed my new stator from elctro-sport.... got around 30VAC and 15DC from the rec/reg....so all looks pretty well right now. We will see how long this stator holds up.
 

·
Registered
Joined
·
11 Posts
Good news. I'm about to do the same thing this weekend. Haven't found the connector yet, but I'm expecting to find - someone else said it the best - "a bar-b-que that I wasn't invited to"....

Hey, Tim, did you just replace the Stator or did you go for the down-rated flywheel too. I spoke to the guys at the UK electrex world, and they only sell the stator with a weaker flywheel, as the magnets on the original are too strong, and that's partly why original RRY and RR1 stators burn.
 

·
Registered
Joined
·
11 Posts
Found the gremlin connector on Sunday, and it was fine :kiss:

So looks like it must be the London commute that fried the stator.... Not surprising when I think that in the last year I've done about 150 return journeys where temperature sits at 95 to 102 degrees C for 20 to 25 mins at a time.... :flame:
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top