Honda Motorcycles - FireBlades.org banner

1 - 9 of 9 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
Yesterday my bike stalled on me 3 times on a highway ride. Bike ran great on the highway but when I came to a stop (light, fuel etc) and only on 3 occasions the bike stalled suddenly with a puff of white smoke out of the front of the bike. The bike restarts without issue. The searching I have done here sounds like it may be a blocked crankcase breather blowing the valve cover gasket ... am I on the right track?. I checked the valves 3 weeks ago, changed the plugs, replaced the CCT. I am on a LONG trip starting Monday so any help you folks could come up with would be greatly appreciated.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #2
Looks like the valve gasket has some leakage to the front of the bike. Where does the crankcase breather usually get blocked / pinched etc...
 

·
Registered
Joined
·
128 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #5
Thanks for the info. I am keeping my fingers crossed for door #1 as I don't need parts for that. If the stator goes my buddy can push start me for the 3000miles as I did for him a bunch of years ago. Karma is a bitch.:evilaugh:
 

·
Registered
Joined
·
157 Posts
Discussion Starter #6 (Edited)
Well GP RZ, turns out you were absolutely right ... the stator went tits up 3 days into the trip. We ended up hot swapping batteries to get us the 700 kms to a buddies place. Ordered the part from RM Stator, replaced and back on the road. I think my stator may have been giving intermittent voltage to the system as we only had to swap batteries once about 15 minutes from my buddies place. Turned out to be a good stay with air shows, hot tubbin' and plenty of those adult soda pops. Didn't get to do the runs we wanted but hey there's always next year right?
 

·
Registered
Joined
·
128 Posts
Glad I can help......just a heads up on RM stator, I just went through 2 of their stator in less the a month, the second on that went they would not replace or even return my calls..... I am not the only 929 owner that has had problems with their stators...I hop you have better luck with your then I did....the current stator thats in my 929 is from a 1983 honda VT500 Ascot, and has been givivng steady voltage for over a month now!
 

·
Registered
Joined
·
157 Posts
Discussion Starter #8
I heard the bad reviews on RM Stator but they were the only folks who could send me one in my time frame to get back home. Fingers crossed been 5 days 1700kms and a dyno run.
 

·
Registered
Joined
·
4 Posts
Hello Andrew, been looking for you all over the place, can you please contact me on emilsoz at gmail dot com? Thanks, EmilsOz from SNM
 
1 - 9 of 9 Posts
Top