Honda Motorcycles - FireBlades.org banner

1 - 11 of 11 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Whats up guy! Once again trying to get some help with my bike! Im having issues with my turn signals. When turned on they just turn on solid, they dont blink at all! I got pulled over about it yesterday and need to fix before court:huh: Hopefully someone can help me out! :idunno::idunno::idunno:

Here a little video of what its doing! Thanks in advance for any input!
 

Attachments

·
Registered
Joined
·
7,455 Posts
Time to replace the turn signal relay. It's in the trunk area. Simple as unplug the old one and plug in the new one.

EDIT: do you have OEM blinkers, or have they been changed to aftermarket. LED's? If so, check out the turn sig relays that are compatible with LED's. I bought mine at Cycle Gear for about $20.
 

·
Registered
Joined
·
752 Posts
Probably the Patriots keychain, check the air in the tires:rotfl:.

They are aftermarket lights and looking at the flicker I would grab the manual and check the wiring for a possible short.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #5
Its cool I'm getting that alot over here :thumb:

I already checked the wiring and everything looks good.
 

·
Registered
Joined
·
242 Posts
Man I wish I knew I could of simply replaced the relay. I changed to LED the other day and ordered the resistor packs. Turns out 10ohms was too much and so worked out it I put two in parallel (5ohms) it worked. Had to nip in today to get a couple of 10ohm resistors today.
Didn't work at first but turned out to be a lose connection. Managed to burn my hand on the soldering iron as well. Nightmare lol.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #7
Thats why Im on here asking before I start messing with it lol Theres guys on here that know these bikes from bottom up, its great!
 

·
Registered
Joined
·
752 Posts
Some setups are two wire or three wire depending if the lights act as marker lights as well as turn indicators. Then the same depends on what the PO purchased two or three wire indicators? It gets confusing until you find out what the OEM setup was, what aftermarket parts were installed and who hacked it in to make it work for them and not necessarily the proper way!
 

·
Registered
Joined
·
61 Posts
Discussion Starter #9
Well what I find weird is that when I purchased the bike they were working but they had a little lagg to them. I'd turn them on and it'd take a couple seconds to turn on. Then they just wouldnt turn on at all and now they do this:idunno:
 
1 - 11 of 11 Posts
Top