Honda Motorcycles - FireBlades.org banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
had my 2nd 929 for over amonth now no issues what so ever, then other day pulle dup at a junction temp was fine, made a loud pop like tyre blowing and a puff of steam from under tank/ fairings, turned bike off, no leaks or fluid anywhere to be seen, oil light and temp ok, left a few mins started up ran fine for another 80 miles home, started to put in garage and same thing any suggestions ? many thanks !!
 

·
Registered
Joined
·
30 Posts
Does the radiator cap have a "pop-off" safety valve? It could be defective and when the coolant pressure reaches a certain point, it vents. Or is the overflow hose to the coolant reservoir off/broken/ leaking? Just a thought.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
i knwo nothing about a safety pop off valve, this is my first port of call ! i wondered if it was over flow cap but was still in place and cant be a hose off else temp would be rising and fluid going all over the place :S thyink when i get back off holiday fairings and tank need to come off and have a damn good look at it ! just such a weird one
 

·
Registered
Joined
·
193 Posts
I had a simuler issue with my 929 blade. but it was'nt steam. it was oil vapour getting ignited by the stator coil windings arcing due to the brake down of the insulation and shorting out. Check your charging rate at the battery. Also check for a sooty residue on the frame by the top yoke. It happens if you do alot of slow town riding and stop start eg trafffic lights. if it is this issue uprated stator and flywheel will be needed.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
ideal il have a look it had a funky smell but was over as soon as the pop happened, got to wait 3weeks to start looking, oh well at least it coming into winter so tinkering time isn't a problem, cheers
 
1 - 5 of 5 Posts
Top